EasyApache 20 Sept Security Release


SUMMARY
cPanel, Inc. has released updated RPMs for EasyApache 4 and EasyApache 3 3.34.16 on September 19, 2017, with a patched versions of Apache 2.2 and 2.4 to address the optionsbleed vulnerability related to CVE-2017-9798. We strongly encourage all Apache 2.2 and 2.4 users to upgrade their system and obtain the patch.

AFFECTED VERSIONS
All versions of Apache 2.4 through 2.4.27
All versions of Apache 2.2 through 2.2.34

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2017-9798 – HIGH

Apache 2.4.27-8
Patched optionsbleed vulnerability related to CVE-2017-9798

Apache 2.2.34
Patched optionsbleed vulnerability related to CVE-2017-9798

SOLUTION
cPanel, Inc. has released EasyApache 3.34.17 with updated versions of Apache 2.2 and Apache 2.4. Unless you have disabled EasyApache updates, the EasyApache application updates to the latest version when launched. Run EasyApache to rebuild your profile with the latest version of Apache.

cPanel, Inc. has released updated RPMs for EasyApache 4 on September 19, 2017, with an updated versions of Apache 2.4. Unless you have enabled automatic RPM updates in your cron, update your system with either yum update or WHM’s Run System Update interface.

REFERENCES
https://nvd.nist.gov/vuln/detail/CVE-2017-9798
https://blog.fuzzing-project.org/60-Optionsbleed-HTTP-OPTIONS-method-can-leak-Apaches-server-memory.html

For the PGP signed message, please see EA4 2017-9-19 CVE



source_link
news.cpanel.com