EasyApache 18 April 2017 Maintenance Release


SUMMARY
cPanel, Inc. has released updated RPMs for EasyApache 4 on April 18, 2017, with PHP versions 7.0.18 and 7.1.4. This release addresses vulnerabilities related to CVE-2017-7272. We strongly encourage all PHP 7.0 users to upgrade to version 7.0.18 and all PHP 7.1 users to upgrade to version 7.1.4.

AFFECTED VERSIONS
All versions of PHP 7.0 through 7.0.17
All versions of PHP 7.1 through 7.1.3

SECURITY RATING
The National Vulnerability Database (NIST) has given the following severity ratings to these CVEs:

CVE-2017-7272 – MEDIUM

PHP 7.0.18
Fixed bug in fsockopen function related to CVE-2017-7272

PHP 7.1.4
Fixed bug in fsockopen function related to CVE-2017-7272

SOLUTION
cPanel, Inc. has released updated RPMs for EasyApache 4 on April 18, 2017, with updated versions of 7.0 and 7.1. Unless you have enabled automatic RPM updates in your cron, update your system with either yum update or WHM’s Run System Update interface.

REFERENCES
https://nvd.nist.gov/vuln/detail/CVE-2017-7272
http://www.php.net/ChangeLog-7.php

For the PGP signed message, please see EA4 2017-4-18 CVE



source_link
news.cpanel.com